Lesson 01

Lesson 01 will take you through the basics of opening a new program in FREE Studio, assigning some
parameters, writing a small application that switches an output depending on a temperature Input.

The Digital Output will Switch On, when temperature exceeds Setpoint + Differential and will switch off
again, when Temperature falls below Setpoint.
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Creating a new program

Start Free Studio Application program by clicking on

free Studio
Application

Click on New project ....

Welcome to Eliwell Free Studio - Application

'El Mew project ...

Type a Name for the project and select Directory where to save it.

Click on the selected PLC type (FreeSmart) to save new project

Welcome to Eliwell Free Studio - Application

LE_!:I Mew project ...

Mame: |LesscunEI 1

Directory: |C: Wzers\Hubert\Dropbox!_ VMWarel32 Free Studiol00 J

Target selection |
E FreeEvolution EVD 423
E FreeEvolution EVC 477
FreeEvalution EVP 439
FreeSmart 412
| Case sensitive

The selection box Case sensitive will differentiate between upper and lower case letters.
E.g. when ticked ‘THEN’ is not the same as ‘then’ and won’t be recognized by the system.

There will always be a default program ‘main’ created. It can but does not have to be used in the
project. The program is assigned to Background, which means that the program will be executed in the
sequence of assigned programs whenever there is time to do so.



All programs assigned to Timed will be executed in a 100ms Intervall.

Init — Programs will be executed only once at initial Start-up.

Boot — Programs will be executed once after every re-Boot.
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Assigning Resources

Definitions
In the Resources Tab following settings are to be made.

EEPROM Parameters — Create Parameters that need to keep value even when power is switched off. In
general , these are parameters that are used in Menus — operational parameters

Status variables — Status variables are created with a modbus address and therefore can be used for
communication with other systems, for example SCADA systems, Modbus Masters, etc.

Enums — are used to set a selection of values that can be assigned to a declared variable. For example 0=
Off, 1= StandBy, 2= On =» Only those three values can be selected if the variable is used in a menu

BIOS Parameters — BIOS Parameters are all settings that are available in every PLC. E.g Modbus Address,
Analog Input configuration,....

Menu Prg — Here are menus assigned that are accessible via Program Menu (Push right two buttons on
SMART) —in general here are parameters assigned that don’t need to be accessed frequently.

Menu set — Here are menus assigned that are accessible via Set Menu (Push bottom right button on
SMART) —in general here are Setpoints assigned that need to be changed regularly

1/0 Mapping:

Local — assign names for all local (On the PLC main unit) Inputs and outputs so they can be addressed in
the program

Extended — assign names for the Inputs and Outputs on an extension unit (only used when extension
unit is present) Project x
Remote — assign names for Inputs on Remote keypad —

Project | = Definitiun3| Resources |

[ Configuration

Alarms — assign names for Alarms. Variables defined EIE FreeSmart_412p6

as Alarms will automatically turn on Alarm indicator -8 Medbus objects

whenever they are not O!! ﬂ EEPROM Parameters
----- &} Status variables
;!E Enums

..... £ BIOS Parameters
..... Menu Prg

..... Menu set

=-B5 /0 Mapping

¥ Alarms




For our first example we only use one Analog Input AIL1 and one Digital Output DOL1. The Name can be
freely assigned (must start with a letter and no spaces allowed).

E_| Project J o3 Dishiniticis Fesources
1 Cenfiguratien
~ [ Freesmart 41206 # hicciecs
_ 5 Modbus objects 1 (ALY
. -4 EEPROM Parameters 2 ALZ
! ,B Status variables 3 AL3
~4) Enumns 4 L4
; _: £ BIOS Parameters E |AlILS
@ Menu Prg & DL
—-BL Menu set -
LfEL Setpoint L
— B2 /0 Mapping y 0D
T B Local § |Dia
@5 Extended 0 DILs
.5 Remote 11 |DILS
& Alarms 12 DOLY

Variable
ainTemperature

douCool

For our example we define a Setpoint and a Differential to be changed via menus.

FreeSmart_412p6
- sl Add R
Modbus objects = Remove
ﬁ EEPRCM F’arameters H Address Mame
g Etat””a”ab'es 1 16384 Setpoint
p B?g_’;ﬂ;arameters 2 18385 Differential

= Recalc

indicate how the parameter is displayed on the smart 4-seg display

7 Segments Preview

e S|

Display label
SEt S
diff 3

Close

Free

&IL1 analogue input
AlLZ analogue input
AIL2 analogue input
AlL4 analogue input
AILS analogue input
DL 1 digital input
DILZ digital input
DL 2 digital input
DiL4 digital input
DILS digital input
DIL6 digital input
COL1 digital output



Application type — indicates the type of variable that is used.

E.g. INT (-32768 to 32768), Bool (TRUE or FALSE)

Default Value — can be downloaded with the program

Min —When parameter is changed via menu the value won’t be lower than minimum value
Max —When parameter is changed via menu the value won’t be higher than maximum value

Application type  Default value Min Max
INT ] -200 500
INT ] 0 50

Unit — If one of the available units selected (C, bar) that unit will displayed with Value on the screen
(only limited to available units on 4-seg display).

Format — Select if decimal point should be displayed. In our case a Setpoint of 500 represents 50.0
degrees, so all temperatures will be represented in the program with 10* their value.

Access Level — Password protection for certain parameters can be set here

LInit Format AccesslLevel
S HOOLY Always visible |
G JOOLY Always visible |

Status Variables
For our example we will only use one Status Variable. The Analog input value we will transfer to this
status variable so we can assign a Unit and Format for display purposes.

Modbus objects — s e = e
a EEPROM Parameters
B Status vanables

%1 Enums

& RIOS Parameters

H Address Mame
1 2960 Temperature

Assign Unit and Format (no other settings necessary)

Lnit Farmat
C HOOLY

Menu

We will only use one Set-Menu for our example. Right click On Menu Set, add a menu and Name it.
Click on ADD and select Setpoint and Differential to be members of this Menu.

H| FreeSmart_412pb
j recamart_step Dizplay label: I_J G Add Q Remove

{| Modbus objects
..{™ EEPROM Parameters

H Mame
- &8 Status variables 1 | Setpoint Setpoint for contral
N E
nums
2 | Differential Differential far Hysterisis

..... £ BIOS Parameters

----- Menu Prg
—:|--- Menu set

L O % Trm o na



First Program
Right Click on Programs, select FBD (Function Block Program), enter a Name and assign to Background
Task.

# Project |~=-O D efinitions | Hesu:uuru:es|

El-- Leszon0l Project I

|__-_|D Programs Mew program
- E main

----- (L3 Function blocks Language |

----- L Functions ] _ - - : e

E—JD Global variables @ 1L @ FED LD ST oSG

----- (L Automatic variables

] Mapped variables Name

e (] Constants firztProgram

El" Tasks Task

=-4% Background Agsign to [Backgrnund v]
: "E it

- £+ Init [ Ok ] [ Cancel

Assign Analog Input to Status Variable
In a first Network we just assign the Analog Input ainTemperature to our Status variable Temperature.

ainTemperature Temperature

First click and drag the Move Block from the library into the Network.

Librany

[E:E L] 451N [e™ ExP =ILmMIT [ I [#[ME
] AC0s ] ATANM [2]GE [ LM [%6] MOD [FIMOT
[+]AD0D hACOS [=]GT log] LOG [:=] MOvE [1]or
[7]ADR [=| Dy [3®]JMP [<]LT [>] MuL [
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If the Library is not visible then click on View > Tool Windows > Library.

Project |°-O Definitions | Fesources

EI-- Legzonll Project . .
&3 Progiams Under the Project Tab open Global shared and Mappings.

B firstProgram Click and drag ainTemperature into the Network and select

L[] main Input when asked. Connect the block then to the left side of

=43 Function blocks the Move Block.
Hyzteresiz
----- [T Functions
=-[_1 Global variables
(2] Automatic variables Network. Select Output when asked. Connect the block to the

-7 Mapped variables right side of the Move Block.

Open Variables and click and drag Temperature into the

(1 Retain variables Now every time this program is executed the Analog Input

E'D falobal Sh‘_are'j value of AIN will be transferred into Status Variable
=[] Mappings

----- [i] ainTemperature Temperature.

Use Hysteresis Block

We will now use a custom made Function block which contains the logic for switching the output on and
off according to Temperature, Setpoint and Differential. The handling and Import/Export of custom
Function blocks, creating of custom Libraries will be explained in another Lesson. Function block
Hysteresis will be used in this example without detailed analysis of the coding in the FB.

Insert a new Network by clicking on

CHyst
L Hysteresis .
Temperature +— Probe_TH Otk TH

Setpoint >— Set TH Prairm_TH
Differential > Dif_TH .

First click and drag the Hysteresis function from the function blocks tree into the Network and name it.

Project |« Definitions

=8 Lezson01 Project
Ela Programs
: "[: firztPragram
LTE] main
=43 Function blocks
: Hysteresis




To the left of the Hysteresis block connect Variable Temperature and Parameters Setpoint and
Differential as previously explained as Inputs.

Connect the Mapping douCool to the right side of the Hysteresis block as Output.

Set Default display
Once the program will be downloaded the PLC will display ‘PLC’ while it is running. In order to display a
default value, in our case Temperature, follow these steps.

Select Resources and click on the first line in the tree view below Configuration. In our case it is
‘FreeSmart_412p6’.

Project » E
Fraject | =2 Definitions | Resources

1 Configuration

- [B] FreeSmart_412p6

EI Modbus objects
. ™ EEPROM Parameters

In the main screen (‘FreeSmart Configuration’) click on the arrow next to Fundamental state display:
and select Temperature from the drop down list.

FreeSmart Configuration

Display

Fundamental
state display: |Temperat|.tre _vJ

Execution time

F1 F2 o
Set execution time: [
~AN -

Cooling Indicator
There are several indicators available on the SMART display that can be utilized — switched on, off,
flashing.

In order to change their display you have to use the Target variable sysLocalleds and set it to 0 (OFF), 1
(ON) or 2 (Flashing).



To find out the instance of the LEDs click Help in tree view on Resources tab.

Praoject | =3 Definitinns| Resources

1 Configuration

= [B] FreeSmart_412p6
=-E8 Medbus objects

P a Status variables

..... £ BIOS Parameters

----- Menu Prg
[—] Menu set

—{® Alarms
g Help

(™ EEPROM Parameters

The LED number we will be using is No. 6 for Cooling. The LED should turn on, when the Cooling Output
in the program is turned on.

LED reference for the developer

The IEC developer can turn on (either steady or blinking) and off the whole range of local display LEDs, by properly setting the array SYSLED.

LED number |Symbol or icon| Description Off On (steady) On (blinking)

: Colon SYSLED[0]=0  |SYSLED[0]=1 _ |SYSLED[0]=2

5%R.H. ¥RH SYSLED[1)=0  [SYSLED[1]=1  |SYSLED[1]=2

2 " Defrost SYSLED[2]=0  [SYSLED[2]=1  |SYSLED[2]=2
[N ]

_Bar Bar SYSLED[3]=0  |SYSLED[3]=1  |SYSLED[3]=2

4 ('_) Stand-by SYSLED[4]=0  |SYSLED[4]=1  |SYSLED[4]=2

_°C b SYSLED[5]=0  |SYSLED[S]=1  |SYSLED[5])=2

6 =2 Cooling SYSLED[6]=0  [SYSLED[6]=1  |SYSLED[6]=2
=

This means that sysLocalLeds[6] must be set to 1 When the Output is on and 0 when the Output is Off.

Insert a new Network by clicking on




SEL

douCool G
] |_ In0
e

In1

sysLocalLeds[8])

From the library Operator and Standard Blocks click and drag the Selector
into the Network.

Connect the Output to the G-Pin of the Selector. The Selector Block will now switch the Value
connected to In0 through to the output whenever is FALSE (=0) and the value connected to In1
whenever is TRUE (=1).

Now connect a constant with Value 0 to INO and a constant with Value 1 to In1 and the LED function
sysLocallLeds[6] to the Output of the Selector Block.

EDDODK

Click on the K-icon and then somewhere in the Network and a constant with value 0 is displayed.
monnt-

Repeat this step and double click on the 0. A window will be displayed and the constant value needs to

be changed to 1. Connect the two constants as described above.

Constant value

Type
OF.
() Exadecimal @ Decimal _

() Octal

Yalue Bool value
1 True
Falze

Now select Target variables in the library menu and click and drag sysLocalLeds into the Network



ayzClock, |I| ayzEmpdnalogOutputs |I| ayzl COAnalogl nputs |I| ayzLocalbnalogOutputs

apgClockE mar ayzE pDigitall nputs szl COLeds syzlocalligitall nputs
syzDizplaytd ode sysEmpOigitaldutputs ayzLCOStatuz sysLocalligitalOutputs
aysEchoStatus zyzE @pStatus @ syzLocaldDCs ayzlocalkeys

zyzE #ptinaloglnputs ayzkeyFunctions |I| syzLocaldnaloglnputs ayzlocalleds

Lr"l Operator and standard blocks | Target variables | Target blocks | basic [

bt
The variable will be displayed without the number for the relevant LED
Double click on and change the name to sysLocallLeds[6].

Connect it as an Output to the Selector Block.



Check for errors
In order to check for errors click on Program Compile

If there are no problems (warnings or errors) the output Window will display 0 warnings, 0 errors

| Output
Fiten data =pace. TR T 0T EBvte)
Free riten data space: Oh [ 0 EBvte)

0 warnings, [0 errors.

|
4| ph Buid /" Findin project | Debug | Fesources [

If the Output window is not visible click on View > Tool Windows > Output.

Conclusion
This is the first simple program written in FreeStudio.

In the next Lesson we will show how to run a Simulation on the screen and download and monitor the
program without connecting to a physical PLC.



